On Fri, Mar 03, 2017 at 06:55:26PM +0200, Andy Shevchenko wrote: > On Tue, Feb 28, 2017 at 4:37 AM, Eva Rachel Retuya <eraretuya@xxxxxxxxx> wrote: > > Add SPI driver that initializes SPI regmap for the adxl345 core driver. > > The driver supports the same functionality as I2C namely the x, y, z and > > scale readings. > > Portion of minor comments. > > > +config ADXL345_SPI > > + tristate "Analog Devices ADXL345 3-Axis Digital Accelerometer SPI Driver" > > > + depends on !(INPUT_ADXL34X=y || INPUT_ADXL34X=m) > > Same question. Would it be just > > depends on INPUT_ADXL34X=n > > ? > > > + /* Setting bits 7 and 6 enables multiple-byte read */ > > + .read_flag_mask = BIT(7) | BIT(6), > > GENMASK(7, 6) ? > True, but I would like to keep this as is. It is more readable and obvious than GENMASK(). > > +static int adxl345_spi_probe(struct spi_device *spi) > > +{ > > > + struct regmap *regmap; > > + const struct spi_device_id *id = spi_get_device_id(spi); > > Reverse order. > > And usually we do assignments from function parameters first. Ack. Thanks, Eva > > > + dev_err(&spi->dev, "Error initializing spi regmap: %d\n", > > + (int)PTR_ERR(regmap)); > > Ugly casting! > > -- > With Best Regards, > Andy Shevchenko -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html