Re: [PATCH V4 07/10] PM / OPP: Separate out _generic_opp_set_rate()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 




On 11/24, Viresh Kumar wrote:
> Later patches would add support for custom opp_set_rate callbacks. This
> patch separates out the code for generic opp_set_rate handler in order
> to prepare for that.

s/opp_set_rate/set_opp/ twice?

> 
> Signed-off-by: Viresh Kumar <viresh.kumar@xxxxxxxxxx>
> Tested-by: Dave Gerlach <d-gerlach@xxxxxx>
> ---

Besides the naming confusion.

Reviewed-by: Stephen Boyd <sboyd@xxxxxxxxxxxxxx>

> @@ -1422,6 +1488,11 @@ int dev_pm_opp_set_regulators(struct device *dev, const char * const names[],
>  
>  	opp_table->regulator_count = count;
>  
> +	/* Allocate block only once to pass to ->set_rate() */

_generic_set_opp()? Or just set_opp when that gets introduced in
the next patch.

> +	ret = _allocate_set_opp_data(opp_table);
> +	if (ret)
> +		goto free_regulators;
> +
>  	mutex_unlock(&opp_table_lock);
>  	return 0;
>  

-- 
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum,
a Linux Foundation Collaborative Project
--
To unsubscribe from this list: send the line "unsubscribe devicetree" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html



[Index of Archives]     [Device Tree Compilter]     [Device Tree Spec]     [Linux Driver Backports]     [Video for Linux]     [Linux USB Devel]     [Linux PCI Devel]     [Linux Audio Users]     [Linux Kernel]     [Linux SCSI]     [XFree86]     [Yosemite Backpacking]
  Powered by Linux