On Monday 09 December 2013, Sergei Ianovich wrote: > anovich wrote: > > On Mon, 2013-12-09 at 02:47 +0100, Arnd Bergmann wrote: > > > On Sunday 08 December 2013, Sergei Ianovich wrote: > > > > + > > > > +#ifdef CONFIG_PXA27x > > > > +extern void __init pxa27x_dt_init_irq(void); > > > > > > +static void __init pxa27x_init_early(void) > > > > +{ > > > > + pxa27x_skip_init(); > > > > +} > > > > > > I would prefer not to have an init_early function at all, and instead > > > check "if (of_have_populated_dt())" in pxa27x_init, or to split > > > that function into two. > > Although this is counterintuitive, it works. Since of_populate_dt() is > not required for of_have_populated_dt() to return true, should we rename > of_have_populated_dt() to of_have_dt()? I don't think it's worth the change. The explanation for the current terminoligy is that of_unflatten() populates the DT device_node structures in the kernel from the FTD blob, while of_platform_populate populates the platform_device infrastructure from the device nodes. Arnd -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html