On 11/27/2013 03:07 PM, Sekhar Nori wrote:
On Wednesday 27 November 2013 04:31 PM, ivan.khoronzhuk wrote:
@@ -192,9 +193,15 @@ static __init void davinci_ntosd2_init(void)
davinci_cfg_reg(DM644X_ATAEN_DISABLE);
/* only one device will be jumpered and detected */
- if (HAS_NAND)
+ if (HAS_NAND) {
platform_device_register(
&davinci_ntosd2_nandflash_device);
+
+ if (davinci_aemif_setup(
+ &davinci_ntosd2_nandflash_device))
+ pr_warn("%s: Cannot configure AEMIF.\n",
+ __func__);
This is looking really ugly. Can you shorten
davinci_ntosd2_nandflash_device to just "ntosd2_nandflash" or similar?
The rename is not related to the patch, so I won't do this.
The reason I asked you to rename is not because I want to push some
random clean-up into this patch. You had to introduce a line so broken
that its almost unreadable. I offered the suggestion as a way to improve
the readability of the code you are introducing in *this* patch.
Thanks,
Sekhar
Ok, I will rename
--
Regards,
Ivan Khoronzhuk
--
To unsubscribe from this list: send the line "unsubscribe devicetree" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html