On Fri, 2013-11-15 at 17:43 +0000, Russell King - ARM Linux wrote: > On Fri, Nov 15, 2013 at 09:03:36AM -0800, Joe Perches wrote: > > On Fri, 2013-11-15 at 17:28 +0100, Florian Meier wrote: > > > +static size_t bcm2835_dma_desc_size_pos(struct bcm2835_desc *d, dma_addr_t addr) > > > +{ > > > + unsigned i; > > > + size_t size; > > > > Please set size to 0 here and not in the for loop > > > + > > > + for (size = i = 0; i < d->frames; i++) { > > I disagree with that comment; I think the above is not only cleaner, but > also more obvious that _this_ loop is calculating _this_ size. I think that using size_t size = 0; is not only _much_ more commonly used throughout the kernel but makes it clearer that the initialization of the return value is done before the loop. Reasonable minds can differ and there is no style guide that prefers one over the other. No matter really to me. As I said, it's trivial. cheers, Joe -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html