On Mon, Jan 04, 2016 at 08:37:30PM +0200, Andy Shevchenko wrote: > > +static int set_priority(struct hidma_mgmt_dev *mdev, unsigned int i, u64 val) > > +{ > > + u64 tmp; > > + int rc; > > + > > + if (i > mdev->dma_channels) > > Shouldn't be >= ? I somehow missed that. There is no merit is posting not related context while replying, makes your emails harder to read, please fix that > > + return -EINVAL; > > + > > + tmp = mdev->priority[i]; > > + mdev->priority[i] = val; > > + rc = hidma_mgmt_setup(mdev); > > + if (rc) > > + mdev->priority[i] = tmp; > > + return rc; > > +} > > + > > +static int set_weight(struct hidma_mgmt_dev *mdev, unsigned int i, u64 val) > > +{ > > + u64 tmp; > > + int rc; > > + > > + if (i > mdev->dma_channels) > > Ditto. Exactly, ditto... -- ~Vinod -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html