On Wed, Dec 09 2015, Andy Shevchenko <andy.shevchenko@xxxxxxxxx> wrote: > On Wed, Dec 9, 2015 at 9:28 PM, Joe Perches <joe@xxxxxxxxxxx> wrote: >> --- >> include/linux/printk.h | 7 +++++++ >> lib/hexdump.c | 39 +++++++++++++++++++++++++++++++-------- >> 2 files changed, 38 insertions(+), 8 deletions(-) >> >> diff --git a/include/linux/printk.h b/include/linux/printk.h >> index 9729565..4be190c 100644 >> --- a/include/linux/printk.h >> +++ b/include/linux/printk.h >> @@ -424,6 +424,13 @@ enum { >> DUMP_PREFIX_ADDRESS, >> DUMP_PREFIX_OFFSET >> }; >> + >> +enum { >> + DUMP_TYPE_CPU = 0, > > And still open this, do we need it? I think you may just mention in > the documentation that default behaviour is CPU like. I think it's best to have a name for the default. In this case it's unlikely to ever be relevant, but in general one could imagine stuff like #ifdef THIS_OR_THAT #define MY_DUMP_TYPE DUMP_TYPE_LE #else #define MY_DUMP_TYPE DUMP_TYPE_CPU #endif which is a lot more readable than if the latter was a naked 0. The feature seems fine to me. It's always been somewhat annoying that grouping changes the order of the byte values on little-endian machines (so grouping is actually a wrong name for it; it's more like "treat the bytes an array of u16/u32/u64"), and one can now get around that by specifying DUMP_TYPE_BE. Rasmus -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html