Hi Mark, Rostislav, On Friday 01 of November 2013 15:58:00 Mark Rutland wrote: > On Tue, Oct 15, 2013 at 11:03:28PM +0100, Rostislav Lisovy wrote: [snip] > > + > > + regulators { > > + compatible = "simple-bus"; > > + > > + reg_3p3v: 3p3v { > > + compatible = "regulator-fixed"; > > + regulator-name = "3P3V"; > > + regulator-min-microvolt = <3300000>; > > + regulator-max-microvolt = <3300000>; > > + regulator-always-on; > > + }; > > + }; > > +}; > > Is there any reason for placing these under a simple-bus rather than > under the root? IMHO readability, if more fixed regulators are likely to be added. However "coding style" is wrong here. It should be something like: regulators { compatible = "simple-bus"; #address-cells = <1>; #size-cells = <0>; reg_3p3v: regulator@0 { compatible = "regulator-fixed"; reg = <0>; regulator-name = "3P3V"; regulator-min-microvolt = <3300000>; regulator-max-microvolt = <3300000>; regulator-always-on; }; }; Note #*-cells and reg properties and child node naming (generic name + @unit-address suffix). Best regards, Tomasz -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html