On Fri, Nov 06, 2015 at 09:27:42AM +1100, Daniel Axtens wrote: >Gavin Shan <gwshan@xxxxxxxxxxxxxxxxxx> writes: > >> >> +void pcibios_setup_bridge(struct pci_bus *bus, unsigned long type) >> +{ >> + struct pci_controller *hose = pci_bus_to_host(bus); >Very much a nit-pick, but I thought we were trying to move towards using >phb instead of hose in new code? > Take PowerNV platform as an example, "hose" means "struct pci_controller", but "phb" means "struct pnv_phb". We don't have the movement to use "phb" to represent "struct pci_controller". >Apart from that this looks good. I would probably have merged it with >the previous patch, but I know Alexey has been suggesting a lot of >splitting and merging previously, so whatever he prefers here is OK. > I'd like to keep them separate as they're for different subsystem: PCI generic subsystem and PowerPC subsystem. Separate maintainers for them can pick them as they will. >> + >> + if (hose->controller_ops.setup_bridge) >> + hose->controller_ops.setup_bridge(bus, type); >> +} >> + >> void pcibios_reset_secondary_bus(struct pci_dev *dev) >> { >> struct pci_controller *phb = pci_bus_to_host(dev->bus); >> -- >> 2.1.0 >> >> -- >> To unsubscribe from this list: send the line "unsubscribe linux-pci" in >> the body of a message to majordomo@xxxxxxxxxxxxxxx >> More majordomo info at http://vger.kernel.org/majordomo-info.html -- To unsubscribe from this list: send the line "unsubscribe devicetree" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html