Helper functions to setproperty with length of property name similar to getprop_namelen variants. This patch series was originally part of overlay-path patch series [0]. [0]: https://lore.kernel.org/devicetree-compiler/6b2dba90-3c52-4933-88f3-b47f96dc7710@xxxxxxxxxxxxxxx/T/#t Signed-off-by: Ayush Singh <ayush@xxxxxxxxxxxxxxx> --- Changes in v2: - Rename fdt_setprop_namelen_placeholder() to fdt_setprop_placeholder_namelen(). - Some formatting changes in fdt_resize_property_(). - Add trailers. - Link to v1: https://lore.kernel.org/r/20241203-setprop-namelen-v1-0-d1ea333fbd6c@xxxxxxxxxxxxxxx --- Ayush Singh (4): libfdt: add fdt_get_property_namelen_w() libfdt_internal: fdt_find_string_len_() libfdt: Add fdt_setprop_namelen() libfdt: Add fdt_setprop_namelen_string() libfdt/fdt.c | 8 ++-- libfdt/fdt_rw.c | 41 +++++++++------- libfdt/libfdt.h | 120 +++++++++++++++++++++++++++++++++++++++++++++-- libfdt/libfdt_internal.h | 11 ++++- libfdt/version.lds | 2 + 5 files changed, 156 insertions(+), 26 deletions(-) --- base-commit: 6f183c7d9246bde8f05d2edbc31fdd497c4a8702 change-id: 20241203-setprop-namelen-a94f7f057acf Best regards, -- Ayush Singh <ayush@xxxxxxxxxxxxxxx>