| > | @@ -545,6 +549,8 @@ struct dccp_sock { | > | __u8 dccps_hc_tx_insert_options:1; | > | __u8 dccps_server_timewait:1; | > | struct timer_list dccps_xmit_timer; | > | + struct queuing_policy *dccps_policy; | > | + void *dccps_policy_data; | > | }; | > | | > | I think this should be just one field for the policy, and the | > | policy_data can be an internal field of `struct queueing_policy' | > | (compare with struct ackvec or struct ccid). | > | --- END --- | > | > Hm, even after reading it again I still find that I don't like void* | > fields. It may be a personal thing, but I think using void* as part of a | > field is bad (and this was in an even earlier comment). | > | The next paragraph was in fact about void* pointers. But the paragraph I | quoted above talks only about whether those three values (policy | numer/pointer, tx_qlen and possibly other data) should be put directly in | struct dccp_sock or grouped in stuct queueing_policy which in turn should be | one field in struct dccp_sock. In the mail from 18/03/2008 you seemed to be | in favour of grouping, in the one from 15/04/2008 you seemed to contradict | your earlier statement. At least that's how I understood it. | But never mind, both ways are ok for me. | -- Those things only became clearer when looking at the code for a while. I have reworked some of your userland code and done some tests with it. There was a bug with the 32-bit compatibility layer, I have posted a message to netdev. On x86 it was found to work correctly. The University of Aberdeen is a charity registered in Scotland, No SC013683. -- To unsubscribe from this list: send the line "unsubscribe dccp" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html