I think we need to get back to deciding on a naming scheme for the structs. It is not your fault, but with the current scheme the names become extremely cryptic: | + * @tfrchcrx_last_counter - Tracks window counter (RFC 4342, 8.1) | + * @tfrchcrx_state - Receiver state, one of %tfrc_hc_rx_states | + * @tfrchcrx_bytes_recv - Total sum of DCCP payload bytes | + * @tfrchcrx_x_recv - Receiver estimate of send rate (RFC 3448, sec. 4.3) | + * @tfrchcrx_rtt - Receiver estimate of RTT | + * @tfrchcrx_last_feedback - Time at which last feedback was sent | + * @tfrchcrx_hist - Packet history, exported by TFRC module | + * @tfrchcrx_li_hist - Loss Interval database, exported by TFRC module | + * @tfrchcrx_s - Received packet size in bytes | + * @tfrchcrx_pinv - Inverse of Loss Event Rate (RFC 4342, sec. 8.5) | + */ Similar thing with the #defines - my eyes fail to parse this: | #define ccid3_hc_tx_sk tfrc_hc_tx_sk | | +#define ccid3_hc_rx_sock tfrc_hc_rx_sock | +#define ccid3hcrx_s tfrchcrx_s | +#define ccid3hcrx_x_recv tfrchcrx_x_recv | +#define ccid3hcrx_pinv tfrchcrx_pinv | +#define ccid3hcrx_last_feedback tfrchcrx_last_feedback | +#define ccid3hcrx_bytes_recv tfrchcrx_bytes_recv | +#define ccid3hcrx_last_counter tfrchcrx_last_counter | +#define ccid3hcrx_rtt tfrchcrx_rtt | +#define ccid3hcrx_s tfrchcrx_s | +#define ccid3hcrx_hist tfrchcrx_hist | +#define ccid3hcrx_li_hist tfrchcrx_li_hist My suggestion is to use something like * `ttx_' for TFRC TX related structs/operations/fields * `trx_' for " RX " " * Arnaldo's scheme for the CCIDs -- c3rx_ / c4rx_ for RX structs/fields -- c3tx_ / c4tx_ for TX structs/fields Of course that costs work. But now is probably the best time to change it - so better get it cleaned up before passing it on to Arnaldo. - To unsubscribe from this list: send the line "unsubscribe dccp" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html