Bug in cyrus-sasl with GSSAPI, encoded packet size too big (4156 > 4096)

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


I have an ongoing problem when using cyrus-sasl > 2.1.23-14 with GSSAPI when trying to send any email over 4096 size. I got around the problem by installing 2.1.23-13 from a SRC RPM in CentOS6.6, since it was not available in repos.
I also was able to solve the problem by using the 2.1.23-15 SRC RPM and commenting out patch 41, which is  "patch41 -p1 -b .ad_compat". I was able to keep patch42 uncommented, so I have already narrowed it down to this ad_compat patch.

I recently tried on CentOS7 and installed everything from repo, configured the same setup which is a cyrus murder using proxyd services in imap config, and still get the same error. If I set it up with the same authentication mechanisms as a standalone server, it works ok.

On CentOS7 I used cyrus-sasl-2.1.26-19.2
rpm -qa | grep cyrus

Please view my bug submitted to RedHat for more details on my setup and configuration. At this point they would like the cyrus-sasl devs to take a look and see if they can help in any way.

Thank You,

[Index of Archives]     [Info Cyrus]     [Squirrel Mail]     [Linux Media]     [Yosemite News]     [gtk]     [KDE]     [Gimp on Windows]     [Steve's Art]

  Powered by Linux