From: Chen Ridong <chenridong@xxxxxxxxxx> The e_freeze flag has been changed to a bool type, which will reduce unnecessary looping when the freezer state does not change. This patch set adds helpers to make the code more concise. Both patch 1 and patch 2 have been reviewed by Michal Koutný. The patch for v3 was dropped, because there was no good idea to make the code much more readable and reduce unesessary loops. --- v4: - drop patch 3, which may make the "cgroup_propagate_frozen" function hard to read. v3: - fix build warnings reported-by kernel test robot. v2: - open code inside the loop of cgroup_freeze instead of inline function. - add helper to make code concise. - remove selftest script(There are hierarchy test in test_freeze.c, I think that is enough for this series). Chen Ridong (2): cgroup/freezer: Reduce redundant traversal for cgroup_freeze cgroup/freezer: Add cgroup CGRP_FROZEN flag update helper include/linux/cgroup-defs.h | 2 +- kernel/cgroup/freezer.c | 97 ++++++++++++++++++------------------- 2 files changed, 47 insertions(+), 52 deletions(-) -- 2.34.1