On Wed, Jan 3, 2024 at 11:20 AM Dan Schatzberg <schatzberg.dan@xxxxxxxxx> wrote: > > On Wed, Jan 03, 2024 at 10:19:40AM -0700, Yu Zhao wrote: > [...] > > > diff --git a/mm/vmscan.c b/mm/vmscan.c > > > index d91963e2d47f..394e0dd46b2e 100644 > > > --- a/mm/vmscan.c > > > +++ b/mm/vmscan.c > > > @@ -92,6 +92,11 @@ struct scan_control { > > > unsigned long anon_cost; > > > unsigned long file_cost; > > > > > > +#ifdef CONFIG_MEMCG > > > + /* Swappiness value for proactive reclaim. Always use sc_swappiness()! */ > > > + int *proactive_swappiness; > > > +#endif > > > > Why is proactive_swappiness still a pointer? The whole point of the > > previous conversation is that sc->proactive can tell whether > > sc->swappiness is valid or not, and that's less awkward than using a > > pointer. > > It's the same reason as before - zero initialization ensures that the > pointer is NULL which tells us if it's valid or not. Proactive reclaim > might not set swappiness and you need to distinguish swappiness of 0 > and not-set. See this discussion with Michal: > > https://lore.kernel.org/linux-mm/ZZUizpTWOt3gNeqR@tiehlicka/ > > > Also why the #ifdef here? I don't see the point for a small stack > > variable. Otherwise wouldn't we want to do this for sc->proactive as > > well? > > This was Michal's request and it feels similar to your rationale for > naming it proactive_swappiness - it's just restricting the interface > down to the only use-cases. I'd be fine with doing the same in > sc->proactive as a subsequent patch. > > See https://lore.kernel.org/linux-mm/ZZUhBoTNgL3AUK3f@tiehlicka/ Also regarding #ifdef, quoting Documentation/process/4.Coding.rst: "As a general rule, #ifdef use should be confined to header files whenever possible."