Re: [PATCH] mm: memcg: remove direct use of __memcg_kmem_uncharge_page

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Dec 13, 2023 at 8:27 AM Matthew Wilcox <willy@xxxxxxxxxxxxx> wrote:
>
> On Wed, Dec 13, 2023 at 08:24:04AM -0800, Yosry Ahmed wrote:
> > I doubt an extra compound_head() will matter in that path, but if you
> > feel strongly about it that's okay. It's a nice cleanup that's all.
>
> i don't even understand why you think it's a nice cleanup.

free_pages_prepare() is directly calling __memcg_kmem_uncharge_page()
instead of memcg_kmem_uncharge_page(), and open-coding checks that
already exist in both of them to avoid the unnecessary function call
if possible. I think this should be the job of
memcg_kmem_uncharge_page(), but it's currently missing the
PageMemcgKmem() check (which is in __memcg_kmem_uncharge_page()).

So I think moving that check to the wrapper allows
free_pages_prepare() to call memcg_kmem_uncharge_page() and without
worrying about those memcg-specific checks.





[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]     [Monitors]

  Powered by Linux