On Wed, Oct 23, 2019 at 04:14:36PM +0200, Michal Hocko wrote: > On Tue 22-10-19 10:47:59, Johannes Weiner wrote: > > Seven years after introducing the global_reclaim() function, I still > > have to double take when reading a callsite. I don't know how others > > do it, this is a terrible name. > > I somehow never had problem with that but ... > > > > Invert the meaning and rename it to cgroup_reclaim(). > > > > [ After all, "global reclaim" is just regular reclaim invoked from the > > page allocator. It's reclaim on behalf of a cgroup limit that is a > > special case of reclaim, and should be explicit - not the reverse. ] > > ... this is a valid point. > > > sane_reclaim() isn't very descriptive either: it tests whether we can > > use the regular writeback throttling - available during regular page > > reclaim or cgroup2 limit reclaim - or need to use the broken > > wait_on_page_writeback() method. Use "writeback_throttling_sane()". > > I do have a stronger opinion on this one. sane_reclaim is really a > terrible name. As you say the only thing this should really tell is > whether writeback throttling is available so I would rather go with > has_writeback_throttling() or writeba_throttling_{eabled,available} > If you insist on having sane in the name then I won't object but it just > raises a question whether we have some levels of throttling with a > different level of sanity. I mean, cgroup1 *does* have a method to not OOM due to pages under writeback: wait_on_page_writeback() on each wb page on the LRU. It's terrible, but it's a form of writeback throttling. That's what the sane vs insane distinction is about, I guess: we do in fact have throttling implementations with different levels of sanity. > > Signed-off-by: Johannes Weiner <hannes@xxxxxxxxxxx> > > Acked-by: Michal Hocko <mhocko@xxxxxxxx> Thanks!