On Wed 21-02-18 12:54:26, Andrew Morton wrote: > On Wed, 21 Feb 2018 09:18:35 -0800 Shakeel Butt <shakeelb@xxxxxxxxxx> wrote: > > > On Wed, Feb 21, 2018 at 8:09 AM, Christopher Lameter <cl@xxxxxxxxx> wrote: > > > Another way to solve this is to switch the user context right? > > > > > > Isnt it possible to avoid these patches if do the allocation in another > > > task context instead? > > > > > > > Sorry, can you please explain what you mean by 'switch the user > > context'. Is there any example in kernel which does something similar? > > > > Another way is by adding a field 'remote_memcg_to_charge' in > > task_struct and set it before the allocation and in memcontrol.c, > > first check if current->remote_memcg_to_charge is set otherwise use > > the memcg of current. Also if we provide a wrapper to do that for the > > user, there will be a lot less plumbing. > > > > Please let me know if you prefer this approach. > > That would be a lot simpler. Passing function arguments via > task_struct is a bit dirty but is sometimes sooo effective. You > should've seen how much mess task_struct.journal_info avoided! And > reclaim_state. Agreed, although from time to time people try to be too creative e.g. with journal_info and surprising bugs come out of that :). > And one always wonders whether we should do a local save/restore before > modifying the task_struct field, so it nests. > > What do others think? Sounds nice to me. > Maybe we can rename task_struct.reclaim_state to `struct task_mm_state > *task_mm_state", add remote_memcg_to_charge to struct task_mm_state and > avoid bloating the task_struct? Yeah, even better, but then we really need to make sure these things stack properly. Honza -- Jan Kara <jack@xxxxxxxx> SUSE Labs, CR -- To unsubscribe from this list: send the line "unsubscribe cgroups" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html