Hello, Aleksa. On Sat, Jun 06, 2015 at 10:02:18AM +1000, Aleksa Sarai wrote: ... > +/* > + * Lockless hierarchical accounting (with enforceable limits) derived from > + * mm/page_counter.c. Original copyright notice from page_counter code: > + * > + * ------------------------------------------------- > + * Lockless hierarchical page accounting & limiting > + * Copyright (C) 2014 Red Hat, Inc., Johannes Weiner > + * ------------------------------------------------- > + */ I don't think we need the above copyright notice. ... > +struct cgroup_subsys pids_cgrp_subsys = { > + .css_alloc = pids_css_alloc, > + .css_free = pids_css_free, > + .attach = pids_attach, > + .can_attach = pids_can_attach, > + .cancel_attach = pids_cancel_attach, > + .can_fork = pids_can_fork, > + .cancel_fork = pids_cancel_fork, > + .fork = pids_fork, > + .exit = pids_exit, > + .legacy_cftypes = files, Please also init dfl_cftypes the same way too. Also, can you please rename files to pids_files? > + .early_init = 0, And the above can be dropped. Other than the above minor points, everything looks good to me but I think we're a bit too close to the merge window to put this in now. Once you update patch 4 and 5 according to the review, I'll apply them after the next rc1 drops. Thanks. -- tejun -- To unsubscribe from this list: send the line "unsubscribe cgroups" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html