Re: [PATCH 1/3] memcg: correct RESOURCE_MAX to ULLONG_MAX and rename it to a better one

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Michal,

On Tue, May 7, 2013 at 9:40 PM, Michal Hocko <mhocko@xxxxxxx> wrote:
> On Sun 05-05-13 23:41:17, Sha Zhengju wrote:
>> Current RESOURCE_MAX(unlimited) is ULONG_MAX, but we can set a bigger value
>
> You have a typo here. The current limit is LLONG_MAX
>
>> than it which is strange. This patch fix it to UULONG_MAX.
>
> and the new one is ULLONG_MAX

Oops... It was most thoughtless of me.

>
>> Notice that this change will affect user output of default *.limit_in_bytes:
>> before change:
>> $ cat /memcg/memory.limit_in_bytes
>> 9223372036854775807
>>
>> after change:
>> $ cat /memcg/memory.limit_in_bytes
>> 18446744073709551615
>>
>> But it doesn't alter the API in term of input - we can still use
>> "echo -1 > *.limit_in_bytes" to reset the numbers to "unlimited".
>>
>> Thanks the suggestions from Andrew and Daisuke Nishimura!
>>
>> Signed-off-by: Sha Zhengju <handai.szj@xxxxxxxxxx>
>
> For the default change
> Acked-by: Michal Hocko <mhocko@xxxxxxx>

Thanks!

>
>> ---
>>  include/linux/res_counter.h |    2 +-
>>  kernel/res_counter.c        |    8 ++++----
>>  mm/memcontrol.c             |    4 ++--
>>  net/ipv4/tcp_memcontrol.c   |   10 +++++-----
>>  4 files changed, 12 insertions(+), 12 deletions(-)
>>
>> diff --git a/include/linux/res_counter.h b/include/linux/res_counter.h
>> index c230994..d7e9056 100644
>> --- a/include/linux/res_counter.h
>> +++ b/include/linux/res_counter.h
>> @@ -54,7 +54,7 @@ struct res_counter {
>>       struct res_counter *parent;
>>  };
>>
>> -#define RESOURCE_MAX (unsigned long long)LLONG_MAX
>> +#define RES_COUNTER_MAX ULLONG_MAX
>
> I do not think the renaming is worth bothering but if you feel it is a
> better match then just do it in a separate patch, please.

I've received comments from Andrew that he suggested we had better
rename it since it is too general. (Sorry, it's my fault that I didn't
mention the change log from V1, I will take care next time. The
previous discussion is here:
http://www.spinics.net/lists/cgroups/msg06788.html). I think we might
as well do it and I'll separate it in next turn.

--
Thanks,
Sha
--
To unsubscribe from this list: send the line "unsubscribe cgroups" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html




[Index of Archives]     [Linux ARM Kernel]     [Linux ARM]     [Linux Omap]     [Fedora ARM]     [IETF Annouce]     [Security]     [Bugtraq]     [Linux OMAP]     [Linux MIPS]     [eCos]     [Asterisk Internet PBX]     [Linux API]     [Monitors]

  Powered by Linux