>> struct mem_cgroup *memcg; >> - int size = sizeof(struct mem_cgroup); >> + int size = memcg_size(); >> >> - /* Can be very big if MAX_NUMNODES is very big */ >> + /* Can be very big if nr_node_ids is very big */ >> if (size < PAGE_SIZE) >> memcg = kzalloc(size, GFP_KERNEL); >> else >> @@ -5933,7 +5943,7 @@ out_free: >> static void __mem_cgroup_free(struct mem_cgroup *memcg) >> { >> int node; >> - int size = sizeof(struct mem_cgroup); >> + int size = memcg_size(); >> >> mem_cgroup_remove_from_trees(memcg); >> free_css_id(&mem_cgroup_subsys, &memcg->css); > > Really everything here should be using size_t - a minor > cosmetic/readability thing. > I agree -- To unsubscribe from this list: send the line "unsubscribe cgroups" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html