This patchset is mainly optimized for readability in contexts where size needs to be determined. By using min() or max(), or even directly removing redundant judgments (such as the 5th patch), the code is more consistent with the context. Li Zetao (8): atm: use min() to simplify the code Bluetooth: use min() to simplify the code net: caif: use max() to simplify the code libceph: use min() to simplify the code net: remove redundant judgments to simplify the code ipv6: mcast: use min() to simplify the code tipc: use min() to simplify the code SUNRPC: use min() to simplify the code net/atm/addr.c | 4 ++-- net/bluetooth/hidp/core.c | 2 +- net/caif/cfpkt_skbuff.c | 6 ++---- net/ceph/messenger.c | 2 +- net/core/sock.c | 2 +- net/ipv6/mcast.c | 5 +++-- net/sunrpc/xdr.c | 2 +- net/tipc/monitor.c | 2 +- 8 files changed, 12 insertions(+), 13 deletions(-) -- 2.34.1