On Wed, 2021-07-14 at 15:35 +0530, Venky Shankar wrote: > v4: > - fix delimiter check in ceph_parse_ips() > - use __func__ in ceph_parse_ips() instead of hardcoded function name > - KERN_NOTICE that mon_addr is recorded but not reconnected > > Venky Shankar (5): > ceph: generalize addr/ip parsing based on delimiter > ceph: rename parse_fsid() to ceph_parse_fsid() and export > ceph: new device mount syntax > ceph: record updated mon_addr on remount > doc: document new CephFS mount device syntax > > Documentation/filesystems/ceph.rst | 25 ++++- > drivers/block/rbd.c | 3 +- > fs/ceph/super.c | 151 +++++++++++++++++++++++++++-- > fs/ceph/super.h | 3 + > include/linux/ceph/libceph.h | 5 +- > include/linux/ceph/messenger.h | 2 +- > net/ceph/ceph_common.c | 17 ++-- > net/ceph/messenger.c | 8 +- > 8 files changed, 186 insertions(+), 28 deletions(-) > I've gone ahead and merged these into the testing branch, though I have not had time to personally do any testing with the new mount helper or new syntax. It does seem to behave fine with the old mount helper and syntax. Venky, I did make a couple of minor changes to this patch: ceph: record updated mon_addr on remount Please take a look when you have time and make sure they're OK. Thanks, -- Jeff Layton <jlayton@xxxxxxxxxx>