v3: - generalize addr parsing based on delimiter - use __func__ is ceph_parse_fsid() - fail mount on conflicting mds_namespaces - mention `ceph fsid` in doc This series introduces changes Ceph File System mount device string. Old mount device syntax (source) has the following problems: mounts to the same cluster but with different fsnames and/or creds have identical device string which can confuse xfstests. Userspace mount helper tool resolves monitor addresses and fill in mon addrs automatically, but that means the device shown in /proc/mounts is different than what was used for mounting. New device syntax is as follows: cephuser@fsid.mycephfs2=/path Note, there is no "monitor address" in the device string. That gets passed in as mount option. This keeps the device string same when monitor addresses change (on remounts). Also note that the userspace mount helper tool is backward compatible. I.e., the mount helper will fallback to using old syntax after trying to mount with the new syntax. Venky Shankar (5): ceph: generalize addr/ip parsing based on delimiter ceph: rename parse_fsid() to ceph_parse_fsid() and export ceph: new device mount syntax ceph: record updated mon_addr on remount doc: document new CephFS mount device syntax Documentation/filesystems/ceph.rst | 25 ++++- drivers/block/rbd.c | 3 +- fs/ceph/super.c | 148 +++++++++++++++++++++++++++-- fs/ceph/super.h | 3 + include/linux/ceph/libceph.h | 5 +- include/linux/ceph/messenger.h | 2 +- net/ceph/ceph_common.c | 17 ++-- net/ceph/messenger.c | 4 +- 8 files changed, 182 insertions(+), 25 deletions(-) -- 2.27.0