On Mon, Jun 28, 2021 at 8:34 PM Jeff Layton <jlayton@xxxxxxxxxx> wrote: > > On Mon, 2021-06-28 at 13:25 +0530, Venky Shankar wrote: > > The new device syntax requires the cluster FSID as part > > of the device string. Use this FSID to verify if it matches > > the cluster FSID we get back from the monitor, failing the > > mount on mismatch. > > > > Signed-off-by: Venky Shankar <vshankar@xxxxxxxxxx> > > --- > > fs/ceph/super.c | 9 +++++++++ > > fs/ceph/super.h | 1 + > > include/linux/ceph/libceph.h | 1 + > > net/ceph/ceph_common.c | 3 ++- > > 4 files changed, 13 insertions(+), 1 deletion(-) > > > > diff --git a/fs/ceph/super.c b/fs/ceph/super.c > > index 950a28ad9c59..84bc06e51680 100644 > > --- a/fs/ceph/super.c > > +++ b/fs/ceph/super.c > > @@ -266,6 +266,9 @@ static int ceph_parse_new_source(const char *dev_name, const char *dev_name_end, > > if (!fs_name_start) > > return invalfc(fc, "missing file system name"); > > > > + if (parse_fsid(fsid_start, &fsopt->fsid)) > > + return invalfc(fc, "invalid fsid format"); > > + > > ++fs_name_start; /* start of file system name */ > > fsopt->mds_namespace = kstrndup(fs_name_start, > > dev_name_end - fs_name_start, GFP_KERNEL); > > @@ -748,6 +751,12 @@ static struct ceph_fs_client *create_fs_client(struct ceph_mount_options *fsopt, > > } > > opt = NULL; /* fsc->client now owns this */ > > > > + /* help learn fsid */ > > + if (fsopt->new_dev_syntax) { > > + ceph_check_fsid(fsc->client, &fsopt->fsid); > > + fsc->client->have_fsid = true; > > + } > > + > > fsc->client->extra_mon_dispatch = extra_mon_dispatch; > > ceph_set_opt(fsc->client, ABORT_ON_FULL); > > > > diff --git a/fs/ceph/super.h b/fs/ceph/super.h > > index 557348ff3203..cfd8ec25a9a8 100644 > > --- a/fs/ceph/super.h > > +++ b/fs/ceph/super.h > > @@ -100,6 +100,7 @@ struct ceph_mount_options { > > char *server_path; /* default NULL (means "/") */ > > char *fscache_uniq; /* default NULL */ > > char *mon_addr; > > + struct ceph_fsid fsid; > > }; > > > > struct ceph_fs_client { > > diff --git a/include/linux/ceph/libceph.h b/include/linux/ceph/libceph.h > > index 409d8c29bc4f..24c1f4e9144d 100644 > > --- a/include/linux/ceph/libceph.h > > +++ b/include/linux/ceph/libceph.h > > @@ -296,6 +296,7 @@ extern bool libceph_compatible(void *data); > > extern const char *ceph_msg_type_name(int type); > > extern int ceph_check_fsid(struct ceph_client *client, struct ceph_fsid *fsid); > > extern void *ceph_kvmalloc(size_t size, gfp_t flags); > > +extern int parse_fsid(const char *str, struct ceph_fsid *fsid); > > > > struct fs_parameter; > > struct fc_log; > > diff --git a/net/ceph/ceph_common.c b/net/ceph/ceph_common.c > > index 97d6ea763e32..db21734462a4 100644 > > --- a/net/ceph/ceph_common.c > > +++ b/net/ceph/ceph_common.c > > @@ -217,7 +217,7 @@ void *ceph_kvmalloc(size_t size, gfp_t flags) > > return p; > > } > > > > -static int parse_fsid(const char *str, struct ceph_fsid *fsid) > > +int parse_fsid(const char *str, struct ceph_fsid *fsid) > > { > > int i = 0; > > char tmp[3]; > > @@ -247,6 +247,7 @@ static int parse_fsid(const char *str, struct ceph_fsid *fsid) > > dout("parse_fsid ret %d got fsid %pU\n", err, fsid); > > return err; > > } > > +EXPORT_SYMBOL(parse_fsid); > > This function name is too generic. Maybe rename it to "ceph_parse_fsid"? Makes sense. ACK. > > > > > /* > > * ceph options > > -- > Jeff Layton <jlayton@xxxxxxxxxx> > -- Cheers, Venky