[PATCH v3 0/6] ceph: convert to netfs helper library

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



This is the third posting of this patchset. The main differences between
this one and the last are some bugfixes, and cleanups:

- rebase onto David's latest fscache-netfs-lib set
- unify the netfs_read_request_ops into one struct
- fix inline_data handling in write_begin
- remove the now-unneeded i_fscache_gen field from ceph_inode_info
- rename gfp_flags to gfp in releasepage
- pass appropriate was_async flag to netfs_subreq_terminated

This set is currently sitting in the ceph-client/testing branch, so
it should get good testing coverage over the next few weeks via in
the teuthology lab.

Jeff Layton (6):
  ceph: disable old fscache readpage handling
  ceph: rework PageFsCache handling
  ceph: fix fscache invalidation
  ceph: convert readpage to fscache read helper
  ceph: plug write_begin into read helper
  ceph: convert ceph_readpages to ceph_readahead

 fs/ceph/Kconfig |   1 +
 fs/ceph/addr.c  | 541 +++++++++++++++++++-----------------------------
 fs/ceph/cache.c | 125 -----------
 fs/ceph/cache.h | 101 +++------
 fs/ceph/caps.c  |  10 +-
 fs/ceph/inode.c |   1 +
 fs/ceph/super.h |   2 +-
 7 files changed, 242 insertions(+), 539 deletions(-)

-- 
2.29.2




[Index of Archives]     [CEPH Users]     [Ceph Large]     [Ceph Dev]     [Information on CEPH]     [Linux BTRFS]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux