> On Nov 17, 2015, at 14:52, Yaowei Bai <baiyaowei@xxxxxxxxxxxxxxxxxxxx> wrote: > > This patch makes ceph_frag_contains_value return bool to improve > readability due to this particular function only using either one or > zero as its return value. > > No functional change. > > Signed-off-by: Yaowei Bai <baiyaowei@xxxxxxxxxxxxxxxxxxxx> > --- > include/linux/ceph/ceph_frag.h | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/include/linux/ceph/ceph_frag.h b/include/linux/ceph/ceph_frag.h > index 970ba5c..b827e06 100644 > --- a/include/linux/ceph/ceph_frag.h > +++ b/include/linux/ceph/ceph_frag.h > @@ -40,7 +40,7 @@ static inline __u32 ceph_frag_mask_shift(__u32 f) > return 24 - ceph_frag_bits(f); > } > > -static inline int ceph_frag_contains_value(__u32 f, __u32 v) > +static inline bool ceph_frag_contains_value(__u32 f, __u32 v) > { > return (v & ceph_frag_mask(f)) == ceph_frag_value(f); > } > -- > 1.9.1 both applied Thanks Yan, Zheng > > > -- To unsubscribe from this list: send the line "unsubscribe ceph-devel" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html