rbd: wrap up of initialization rework

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



These four patches sort of finish out this bunch of patches
that have been reworking how rbd initialization of devices
is done.  With this foundation in place, probing for
parents of layered device fits in fairly neatly.

[PATCH 1/4] rbd: don't pass rbd_dev to rbd_get_client()
    This makes getting a reference to a client not depend
    on a particular rbd_dev.
[PATCH 2/4] rbd: consolidate rbd_dev init in rbd_add()
    This just moves some code around to make the next patch
    simpler.
[PATCH 3/4] rbd: define rbd_dev_{create,destroy}() helpers
    These helpers isolate some initialization and make
    cleanup in error paths easier.
[PATCH 4/4] rbd: encapsulate last part of probe
    This moves a big hunk of code into its own function,
    leaving rbd_add() much shorter and easier to follow.

					-Alex
--
To unsubscribe from this list: send the line "unsubscribe ceph-devel" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [CEPH Users]     [Ceph Large]     [Information on CEPH]     [Linux BTRFS]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]

  Powered by Linux