old website keep reappering in /var/www/html

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

absurd subject, but I don't know how else I could describe what is happening.
I have a small static website hosted on a Centos 7 VPS (that I'll update as soon as possible, but what follows is much more urgent, I must absolutely fix it asap).
The website is generated by Hugo. I run hugo on my computer, then rsync everything on the server, in the /var/www/html/hugo/MYWEBSITE folder.
Everything worked great for years.
This week I rebuilt the whole website almost from scratch, using a different hugo theme and updating many pages.
Then I ran rsync, checked the new website in my browser, jumping from page to page, and everything worked as expected: new theme, new content, new menus, everything.
2/3 minutes later, the OLD website reappeared, all of it, as if I had not ran rsync at all. For example, in the new website there is a new subfolder called "bio", that did not exist in the old version.

If I ssh to the server, cd to /var/www/html/hugo/MYWEBSITE  and run "ls -l" RIGHT AFTER running rsync, I see the "bio" subfolder. If I do "ls -l" 3 minutes later, the "bio" subfolder is no more.

I have repeated the rsync process 5/6 times before writing this email, and it's always the same. Every time I rsync, what I uploaded lasts 2/3 minutes, then the WHOLE folder on the server is erased and refilled with the previous full version of the website.

It's as if there were some hidden cron job somewhere that runs hugo on the OLD source files, but I can't find it. All the standard methods one can find by googling "how to list all cron jobs" don't show anything that may be the reason.
THANKS in advance for any help,
CentOS mailing list

[Index of Archives]     [CentOS]     [CentOS Announce]     [CentOS Development]     [CentOS ARM Devel]     [CentOS Docs]     [CentOS Virtualization]     [Carrier Grade Linux]     [Linux Media]     [Asterisk]     [DCCP]     [Netdev]     [Xorg]     [Linux USB]

  Powered by Linux