Re: Clocksource boot issues 4.9.13

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


On 04/02/2017 02:49 AM, Chris Elliott wrote:
> Hi all
> I’ve got a few Intel Z87 chipset machines with Adaptec 5405 raid cards (latest firmware), they work fine on 3.18 but during Dom0 boot using kernel
> 4.9.13 it hangs at “Using clocksource tsc” and the aacraid driver keeps trying to reset
> Has anyone seen anything like this?
> I’ve tried specifying clocksource=xen in grub instead of the default of tsc, and that has the same issue. HPET is enabled and Xen is seeing it:
> (XEN) ACPI: HPET D9649CB0, 0038 (r1 ALASKA    A M I  1072009 AMI.        5) (XEN) Platform timer is 14.318MHz HPET

I saw a hang at a similar place in the boot process when trying to boot xen-on-xen for our test system. On a hunch I was going to to try recompiling
without the PVHVM PCI related driver (pci-platform ? platform-pci ? ) before saying anything about it.

Since you tried changing the clock source I'm wondering is that the boot issue is unrelated to the clock source, in which case you may get a better
idea of what's hanging by comparing the boot logs from 3.18 to 4.9 and seeing what's present in 3.18 but not in 4.9. Presumably the messages in the
3.18 but not 4.9 logs are either removed from the kernel source or happen after whatever is hanging.

CentOS-virt mailing list

[Index of Archives]     [CentOS Users]     [Linux Media]     [Asterisk]     [DCCP]     [Netdev]     []     [Xfree86]     [Linux USB]

  Powered by Linux