Re: unable to execute QEMU command 'migrate': this feature or command is not currently supported

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Dear Xlord

Please check if the VM guest has vm-tools installed else the “virsh
migrate --live” parameter requirement is not fulfilled else you has to
turn off the VM guest and do the offline “virsh migrate” without
“--live” options. Hope that helps.

As far as I know (and it definitely worked in CentOS 6 and from CentOS 6
to CentOS 7) no guest tools are needed. But I tried it nevertheless:
did not work :(

Live migration with shared storage works fine but in my case I need
to do live migrations without shared storage (in order to free running
hosts to upgrade their OSes and setup shared storage)

I suspect either that the qemu-kvm binary from qemu-kvm-ev-2.6.0-28 is
missing this feature or it is called without a needed option. Comparing
running qemu-kvm processes on CentOS 6 and CentOS 7 I can see that
those on CentOS 6 have -enable-kvm on the command lime but those
on CentOS 7 have not.

How can the qemu-kvm binary be checked to see if the feature is enabled?

Thanks, Valentin
CentOS-virt mailing list

[Index of Archives]     [CentOS Users]     [Linux Media]     [Asterisk]     [DCCP]     [Netdev]     []     [Xfree86]     [Linux USB]

  Powered by Linux