Benjamin Gray <bgray@xxxxxxxxxxxxx> writes: > Python 3.6 introduced a DeprecationWarning for invalid escape sequences. > This is upgraded to a SyntaxWarning in Python 3.12, and will eventually > be a syntax error. > > Fix these now to get ahead of it before it's an error. > > Signed-off-by: Benjamin Gray <bgray@xxxxxxxxxxxxx> > --- > Documentation/sphinx/cdomain.py | 2 +- > Documentation/sphinx/kernel_abi.py | 2 +- > Documentation/sphinx/kernel_feat.py | 2 +- > Documentation/sphinx/kerneldoc.py | 2 +- > Documentation/sphinx/maintainers_include.py | 8 ++++---- > 5 files changed, 8 insertions(+), 8 deletions(-) So I am the maintainer for this stuff...is there a reason you didn't copy me on this work? > diff --git a/Documentation/sphinx/cdomain.py b/Documentation/sphinx/cdomain.py > index ca8ac9e59ded..dbdc74bd0772 100644 > --- a/Documentation/sphinx/cdomain.py > +++ b/Documentation/sphinx/cdomain.py > @@ -93,7 +93,7 @@ def markup_ctype_refs(match): > # > RE_expr = re.compile(r':c:(expr|texpr):`([^\`]+)`') > def markup_c_expr(match): > - return '\ ``' + match.group(2) + '``\ ' > + return '\\ ``' + match.group(2) + '``\\ ' I have to wonder about this one; I doubt the intent was to insert a literal backslash. I have to fire up my ancient build environment to even try this, but even if it's right... > # > # Parse Sphinx 3.x C markups, replacing them by backward-compatible ones > diff --git a/Documentation/sphinx/kernel_abi.py b/Documentation/sphinx/kernel_abi.py > index b5feb5b1d905..b9f026f016fd 100644 > --- a/Documentation/sphinx/kernel_abi.py > +++ b/Documentation/sphinx/kernel_abi.py > @@ -138,7 +138,7 @@ class KernelCmd(Directive): > code_block += "\n " + l > lines = code_block + "\n\n" > > - line_regex = re.compile("^\.\. LINENO (\S+)\#([0-9]+)$") > + line_regex = re.compile("^\\.\\. LINENO (\\S+)\\#([0-9]+)$") All of these really just want to be raw strings - a much more minimal fix that makes the result quite a bit more readable: line_regex = re.compile(r"^\.\. LINENO (\S+)\#([0-9]+)$") ^ | ---------------------------+ That, I think, is how these should be fixed. Thanks, jon