On Sat, 15 Jul 2023 at 04:21, Alexei Starovoitov <alexei.starovoitov@xxxxxxxxx> wrote: > > On Thu, Jul 13, 2023 at 08:02:28AM +0530, Kumar Kartikeya Dwivedi wrote: > > diff --git a/tools/testing/selftests/bpf/bpf_experimental.h b/tools/testing/selftests/bpf/bpf_experimental.h > > index 209811b1993a..f1d7de1349bc 100644 > > --- a/tools/testing/selftests/bpf/bpf_experimental.h > > +++ b/tools/testing/selftests/bpf/bpf_experimental.h > > @@ -131,4 +131,10 @@ extern int bpf_rbtree_add_impl(struct bpf_rb_root *root, struct bpf_rb_node *nod > > */ > > extern struct bpf_rb_node *bpf_rbtree_first(struct bpf_rb_root *root) __ksym; > > > > +__attribute__((noreturn)) > > +extern void bpf_throw(u64 cookie) __ksym; > > + > > +#define throw bpf_throw(0) > > +#define throw_value(cookie) bpf_throw(cookie) > > Reading the patch 10 I think the add-on value of these two macros is negative. > If it was open coded as bpf_throw(0); everywhere it would be easier to read imo. Ack, I will drop the macros.