Hi Florian, On Tue, Jun 27, 2023 at 01:58:39PM +0200, Florian Westphal wrote: > Call bpf_program__attach_netfilter() with different > protocol/hook/priority combinations. > > Test fails if supposedly-illegal attachments work > (e.g., bogus protocol family, illegal priority and so on) or if a > should-work attachment fails. Expected output: > > ./test_progs -t netfilter_link_attach > #145/1 netfilter_link_attach/netfilter link attach 0:OK > #145/2 netfilter_link_attach/netfilter link attach 1:OK > #145/3 netfilter_link_attach/netfilter link attach 2:OK > #145/4 netfilter_link_attach/netfilter link attach 3:OK > #145/5 netfilter_link_attach/netfilter link attach 4:OK > #145/6 netfilter_link_attach/netfilter link attach 5:OK > #145/7 netfilter_link_attach/netfilter link attach 6:OK > #145/8 netfilter_link_attach/netfilter link attach 7:OK > #145/9 netfilter_link_attach/netfilter link attach 8:OK > #145 netfilter_link_attach:OK > > Signed-off-by: Florian Westphal <fw@xxxxxxxxx> > --- > .../bpf/prog_tests/netfilter_link_attach.c | 88 +++++++++++++++++++ > .../bpf/progs/test_netfilter_link_attach.c | 14 +++ > 2 files changed, 102 insertions(+) > create mode 100644 tools/testing/selftests/bpf/prog_tests/netfilter_link_attach.c > create mode 100644 tools/testing/selftests/bpf/progs/test_netfilter_link_attach.c > > diff --git a/tools/testing/selftests/bpf/prog_tests/netfilter_link_attach.c b/tools/testing/selftests/bpf/prog_tests/netfilter_link_attach.c > new file mode 100644 > index 000000000000..dfec6c44f81d > --- /dev/null > +++ b/tools/testing/selftests/bpf/prog_tests/netfilter_link_attach.c > @@ -0,0 +1,88 @@ > +// SPDX-License-Identifier: GPL-2.0-or-later > + > +#include <netinet/in.h> > +#include <linux/netfilter.h> > + > +#include "test_progs.h" > +#include "test_netfilter_link_attach.skel.h" > + > +struct nf_link_test { > + __u32 pf; > + __u32 hooknum; > + __s32 priority; > + __u32 flags; > + > + bool expect_success; > +}; > + > +struct nf_link_test nf_hook_link_tests[] = { > + { }, > + { .pf = NFPROTO_NUMPROTO, }, > + { .pf = NFPROTO_IPV4, .hooknum = 42, }, > + { .pf = NFPROTO_IPV4, .priority = INT_MIN }, > + { .pf = NFPROTO_IPV4, .priority = INT_MAX }, > + { .pf = NFPROTO_IPV4, .flags = UINT_MAX }, > + > + { .pf = NFPROTO_INET, .priority = 1, }, > + > + { .pf = NFPROTO_IPV4, .priority = -10000, .expect_success = true }, > + { .pf = NFPROTO_IPV6, .priority = 10001, .expect_success = true }, > +}; > + > +void test_netfilter_link_attach(void) > +{ > + struct test_netfilter_link_attach *skel; > + struct bpf_program *prog; > + LIBBPF_OPTS(bpf_netfilter_opts, opts); > + int i; > + > + skel = test_netfilter_link_attach__open_and_load(); > + if (!ASSERT_OK_PTR(skel, "test_netfilter_link_attach__open_and_load")) > + goto out; > + > + prog = skel->progs.nf_link_attach_test; > + if (!ASSERT_OK_PTR(prog, "attach program")) > + goto out; > + > + for (i = 0; i < ARRAY_SIZE(nf_hook_link_tests); i++) { > + struct bpf_link *link; > + char name[128]; > + > + snprintf(name, sizeof(name), "netfilter link attach %u", i); > + > + if (!test__start_subtest(name)) > + continue; Nit: naming by index makes it a little annoying to debug failures. How about adding a name field to struct nf_link_test? [...] Thanks, Daniel