Re: [PATCH v5 bpf-next 0/8] BPF open-coded iterators

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hello:

This series was applied to bpf/bpf-next.git (master)
by Alexei Starovoitov <ast@xxxxxxxxxx>:

On Wed, 8 Mar 2023 10:41:13 -0800 you wrote:
> Add support for open-coded (aka inline) iterators in BPF world. This is a next
> evolution of gradually allowing more powerful and less restrictive looping and
> iteration capabilities to BPF programs.
> 
> We set up a framework for implementing all kinds of iterators (e.g., cgroup,
> task, file, etc, iterators), but this patch set only implements numbers
> iterator, which is used to implement ergonomic bpf_for() for-like construct
> (see patches #4-#5). We also add bpf_for_each(), which is a generic
> foreach-like construct that will work with any kind of open-coded iterator
> implementation, as long as we stick with bpf_iter_<type>_{new,next,destroy}()
> naming pattern (which we now enforce on the kernel side).
> 
> [...]

Here is the summary with links:
  - [v5,bpf-next,1/8] bpf: factor out fetching basic kfunc metadata
    https://git.kernel.org/bpf/bpf-next/c/07236eab7a31
  - [v5,bpf-next,2/8] bpf: add iterator kfuncs registration and validation logic
    https://git.kernel.org/bpf/bpf-next/c/215bf4962f6c
  - [v5,bpf-next,3/8] bpf: add support for open-coded iterator loops
    https://git.kernel.org/bpf/bpf-next/c/06accc8779c1
  - [v5,bpf-next,4/8] bpf: implement numbers iterator
    https://git.kernel.org/bpf/bpf-next/c/6018e1f407cc
  - [v5,bpf-next,5/8] selftests/bpf: add bpf_for_each(), bpf_for(), and bpf_repeat() macros
    https://git.kernel.org/bpf/bpf-next/c/8c2b5e90505e
  - [v5,bpf-next,6/8] selftests/bpf: add iterators tests
    https://git.kernel.org/bpf/bpf-next/c/57400dcce6c2
  - [v5,bpf-next,7/8] selftests/bpf: add number iterator tests
    https://git.kernel.org/bpf/bpf-next/c/f59b14609265
  - [v5,bpf-next,8/8] selftests/bpf: implement and test custom testmod_seq iterator
    https://git.kernel.org/bpf/bpf-next/c/7e86a8c4ac8d

You are awesome, thank you!
-- 
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html





[Index of Archives]     [Linux Samsung SoC]     [Linux Rockchip SoC]     [Linux Actions SoC]     [Linux for Synopsys ARC Processors]     [Linux NFS]     [Linux NILFS]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]


  Powered by Linux