Hello: This series was applied to bpf/bpf-next.git (master) by Alexei Starovoitov <ast@xxxxxxxxxx>: On Thu, 2 Mar 2023 15:49:58 -0800 you wrote: > Add support for open-coded (aka inline) iterators in BPF world. This is a next > evolution of gradually allowing more powerful and less restrictive looping and > iteration capabilities to BPF programs. > > We set up a framework for implementing all kinds of iterators (e.g., cgroup, > task, file, etc, iterators), but this patch set only implements numbers > iterator, which is used to implement ergonomic bpf_for() for-like construct > (see patch #15). We also add bpf_for_each(), which is a generic foreach-like > construct that will work with any kind of open-coded iterator implementation, > as long as we stick with bpf_iter_<type>_{new,next,destroy}() naming pattern. > > [...] Here is the summary with links: - [bpf-next,01/17] bpf: improve stack slot state printing https://git.kernel.org/bpf/bpf-next/c/d54e0f6c1adf - [bpf-next,02/17] bpf: improve regsafe() checks for PTR_TO_{MEM,BUF,TP_BUFFER} https://git.kernel.org/bpf/bpf-next/c/567da5d253cd - [bpf-next,03/17] selftests/bpf: enhance align selftest's expected log matching https://git.kernel.org/bpf/bpf-next/c/6f876e75d316 - [bpf-next,04/17] bpf: honor env->test_state_freq flag in is_state_visited() https://git.kernel.org/bpf/bpf-next/c/98ddcf389d1b - [bpf-next,05/17] selftests/bpf: adjust log_fixup's buffer size for proper truncation https://git.kernel.org/bpf/bpf-next/c/fffc893b6bf2 - [bpf-next,06/17] bpf: clean up visit_insn()'s instruction processing https://git.kernel.org/bpf/bpf-next/c/653ae3a874ac - [bpf-next,07/17] bpf: fix visit_insn()'s detection of BPF_FUNC_timer_set_callback helper https://git.kernel.org/bpf/bpf-next/c/c1ee85a9806a - [bpf-next,08/17] bpf: ensure that r0 is marked scratched after any function call https://git.kernel.org/bpf/bpf-next/c/553a64a85c5d - [bpf-next,09/17] bpf: move kfunc_call_arg_meta higher in the file https://git.kernel.org/bpf/bpf-next/c/d0e1ac227945 - [bpf-next,10/17] bpf: mark PTR_TO_MEM as non-null register type https://git.kernel.org/bpf/bpf-next/c/d5271c5b1950 - [bpf-next,11/17] bpf: generalize dynptr_get_spi to be usable for iters https://git.kernel.org/bpf/bpf-next/c/a461f5adf177 - [bpf-next,12/17] bpf: add support for fixed-size memory pointer returns for kfuncs https://git.kernel.org/bpf/bpf-next/c/f4b4eee6169b - [bpf-next,13/17] bpf: add support for open-coded iterator loops (no matching commit) - [bpf-next,14/17] bpf: implement number iterator (no matching commit) - [bpf-next,15/17] selftests/bpf: add bpf_for_each(), bpf_for(), and bpf_repeat() macros (no matching commit) - [bpf-next,16/17] selftests/bpf: add iterators tests (no matching commit) - [bpf-next,17/17] selftests/bpf: add number iterator tests (no matching commit) You are awesome, thank you! -- Deet-doot-dot, I am a bot. https://korg.docs.kernel.org/patchwork/pwbot.html