From: Martin Kafai Lau <martin.lau@xxxxxxxxx> Date: Tue, 21 Feb 2023 09:52:52 -0800 > On 2/21/23 4:35 AM, Alexander Lobakin wrote: >> From: Alexander Lobakin <aleksander.lobakin@xxxxxxxxx> >> Date: Mon, 20 Feb 2023 16:46:27 +0100 >> >>> &xdp_buff and &xdp_frame are bound in a way that >>> >>> xdp_buff->data_hard_start == xdp_frame >>> >>> It's always the case and e.g. xdp_convert_buff_to_frame() relies on >>> this. >>> IOW, the following: >>> >>> for (u32 i = 0; i < 0xdead; i++) { >>> xdpf = xdp_convert_buff_to_frame(&xdp); >>> xdp_convert_frame_to_buff(xdpf, &xdp); >>> } >>> >>> shouldn't ever modify @xdpf's contents or the pointer itself. >>> However, "live packet" code wrongly treats &xdp_frame as part of its >>> context placed *before* the data_hard_start. With such flow, >>> data_hard_start is sizeof(*xdpf) off to the right and no longer points >>> to the XDP frame. >>> >>> Instead of replacing `sizeof(ctx)` with `offsetof(ctx, xdpf)` in several >>> places and praying that there are no more miscalcs left somewhere in the >>> code, unionize ::frm with ::data in a flex array, so that both starts >>> pointing to the actual data_hard_start and the XDP frame actually starts >>> being a part of it, i.e. a part of the headroom, not the context. >>> A nice side effect is that the maximum frame size for this mode gets >>> increased by 40 bytes, as xdp_buff::frame_sz includes everything from >>> data_hard_start (-> includes xdpf already) to the end of XDP/skb shared >>> info. >>> Also update %MAX_PKT_SIZE accordingly in the selftests code. Leave it >>> hardcoded for 64 bit && 4k pages, it can be made more flexible later on. >>> >>> Minor: align `&head->data` with how `head->frm` is assigned for >>> consistency. >>> Minor #2: rename 'frm' to 'frame' in &xdp_page_head while at it for >>> clarity. >>> >>> (was found while testing XDP traffic generator on ice, which calls >>> xdp_convert_frame_to_buff() for each XDP frame) >> >> Sorry, maybe this could be taken directly to net-next while it's still >> open? It was tested and then reverted from bpf-next only due to not 100% >> compile-time assertion, which I removed in this version. No more >> changes. I doubt there'll be a second PR from bpf and would like this to >> hit mainline before RC1 :s > > I think this could go to bpf soon instead of bpf-next. The change is > specific to the bpf selftest. It is better to go through bpf to get bpf > CI coverage. Ah okay, I'll resend when bpf pulls merged net-next from Linus' tree. > >> >>> >>> Fixes: b530e9e1063e ("bpf: Add "live packet" mode for XDP in >>> BPF_PROG_RUN") >>> Acked-by: Toke Høiland-Jørgensen <toke@xxxxxxxxxx> >>> Signed-off-by: Alexander Lobakin <aleksander.lobakin@xxxxxxxxx> >>> Link: >>> https://lore.kernel.org/r/20230215185440.4126672-1-aleksander.lobakin@xxxxxxxxx >>> Signed-off-by: Martin KaFai Lau <martin.lau@xxxxxxxxxx> >> (>_< those two last tags are incorrect, lemme know if I should resubmit >> it without them or you could do it if ok with taking it now) > > Please respin when it can be landed to the bpf tree on top of the s390 > changes. Thanks, Olek