On Tue, 2022-09-06 at 00:38 +0300, Jarkko Sakkinen wrote: > On Mon, Sep 05, 2022 at 04:33:11PM +0200, Roberto Sassu wrote: > > From: Roberto Sassu <roberto.sassu@xxxxxxxxxx> > > > > In preparation for the patch that introduces the > > bpf_lookup_user_key() eBPF > > kfunc, move KEY_LOOKUP_ definitions to include/linux/key.h, to be > > able to > > validate the kfunc parameters. Add them to enum key_lookup_flag, so > > that > > all the current ones and the ones defined in the future are > > automatically > > exported through BTF and available to eBPF programs. > > > > Also, add KEY_LOOKUP_ALL to the enum, to facilitate checking > > whether a > > variable contains only defined flags. > > > > Signed-off-by: Roberto Sassu <roberto.sassu@xxxxxxxxxx> > > Reviewed-by: KP Singh <kpsingh@xxxxxxxxxx> > > Acked-by: Jarkko Sakkinen <jarkko@xxxxxxxxxx> > > You should remove ack if there is any substantial change. Yes, sorry. I thought you were fine with the change due to: https://lore.kernel.org/bpf/YxF4H9MTDj+PnJ+V@xxxxxxxxxx/ > > > --- > > include/linux/key.h | 6 ++++++ > > security/keys/internal.h | 2 -- > > 2 files changed, 6 insertions(+), 2 deletions(-) > > > > diff --git a/include/linux/key.h b/include/linux/key.h > > index 7febc4881363..d84171f90cbd 100644 > > --- a/include/linux/key.h > > +++ b/include/linux/key.h > > @@ -88,6 +88,12 @@ enum key_need_perm { > > KEY_DEFER_PERM_CHECK, /* Special: permission check is > > deferred */ > > }; > > > > +enum key_lookup_flag { > > + KEY_LOOKUP_CREATE = 0x01, /* Create special keyrings if they > > don't exist */ > > + KEY_LOOKUP_PARTIAL = 0x02, /* Permit partially constructed > > keys to be found */ > > + KEY_LOOKUP_ALL = (KEY_LOOKUP_CREATE | KEY_LOOKUP_PARTIAL), /* > > OR of previous flags */ > > Drop the comments (should be reviewed separately + out of context). The same style is used for many definitions in include/linux/key.h No problem to remove them, please just let me know where they should be. Often, eBPF maintainers asked me to add a description to the code to explain how new definitions should be used. Thanks Roberto