On Wed, Jul 27, 2022 at 10:16:28AM +0200, Eric Dumazet wrote: > On Wed, Jul 27, 2022 at 8:09 AM Martin KaFai Lau <kafai@xxxxxx> wrote: > > > > A latter patch refactors bpf_setsockopt(SOL_SOCKET) with the > > sock_setsockopt() to avoid code duplication and code > > drift between the two duplicates. > > > > The current sock_setsockopt() takes sock ptr as the argument. > > The very first thing of this function is to get back the sk ptr > > by 'sk = sock->sk'. > > > > bpf_setsockopt() could be called when the sk does not have > > a userspace owner. Meaning sk->sk_socket is NULL. For example, > > when a passive tcp connection has just been established. Thus, > > it cannot use the sock_setsockopt(sk->sk_socket) or else it will > > pass a NULL sock ptr. > > > > All existing callers have both sock->sk and sk->sk_socket pointer. > > Thus, this patch changes the sock_setsockopt() to take a sk ptr > > instead of the sock ptr. The bpf_setsockopt() only allows > > optnames that do not require a sock ptr. > > > > Signed-off-by: Martin KaFai Lau <kafai@xxxxxx> > > --- > > ... > > > diff --git a/include/net/sock.h b/include/net/sock.h > > index f7ad1a7705e9..9e2539dcc293 100644 > > --- a/include/net/sock.h > > +++ b/include/net/sock.h > > @@ -1795,7 +1795,7 @@ void sock_pfree(struct sk_buff *skb); > > #define sock_edemux sock_efree > > #endif > > > > -int sock_setsockopt(struct socket *sock, int level, int op, > > +int sock_setsockopt(struct sock *sk, int level, int op, > > sockptr_t optval, unsigned int optlen); > > > > SGTM, but I feel we should rename this to sk_setsockopt() ? Ah, right. will rename it.