This set is a follow up on the bpf side based on discussion [0]. Patch 1 is to remove some skbuff macros that are used in bpf filter.c Patch 2 and 3 are to simplify the bpf insn rewrite on __sk_buff->tstamp. Patch 4 is to simplify the bpf uapi by modeling the __sk_buff->tstamp and __sk_buff->tstamp_type (was delivery_time_type) the same as its kernel counter part skb->tstamp and skb->mono_delivery_time. Patch 5 is to adjust the bpf selftests due to changes in patch 4. [0]: https://lore.kernel.org/bpf/419d994e-ff61-7c11-0ec7-11fefcb0186e@xxxxxxxxxxxxx/ Martin KaFai Lau (5): bpf: net: Remove TC_AT_INGRESS_OFFSET and SKB_MONO_DELIVERY_TIME_OFFSET macro bpf: Simplify insn rewrite on BPF_READ __sk_buff->tstamp bpf: Simplify insn rewrite on BPF_WRITE __sk_buff->tstamp bpf: Remove BPF_SKB_DELIVERY_TIME_NONE and rename s/delivery_time_/tstamp_/ bpf: selftests: Update tests after s/delivery_time/tstamp/ change in bpf.h include/linux/filter.h | 2 +- include/linux/skbuff.h | 10 +- include/uapi/linux/bpf.h | 40 +++--- net/core/filter.c | 133 ++++++++---------- tools/include/uapi/linux/bpf.h | 40 +++--- .../selftests/bpf/progs/test_tc_dtime.c | 38 ++--- 6 files changed, 125 insertions(+), 138 deletions(-) -- 2.30.2