On Tue, Oct 26, 2021 at 5:16 AM Kees Cook <keescook@xxxxxxxxxxxx> wrote: > > On Mon, Oct 25, 2021 at 08:33:07AM +0000, Yafang Shao wrote: > > Use strscpy_pad() instead of strlcpy() to make the comm always nul > > terminated. As the comment above the hard-coded 16, we can replace it > > with TASK_COMM_LEN, then it will adopt to the comm size change. > > > > Signed-off-by: Yafang Shao <laoar.shao@xxxxxxxxx> > > Cc: Mathieu Desnoyers <mathieu.desnoyers@xxxxxxxxxxxx> > > Cc: Arnaldo Carvalho de Melo <arnaldo.melo@xxxxxxxxx> > > Cc: Andrii Nakryiko <andrii.nakryiko@xxxxxxxxx> > > Cc: Peter Zijlstra <peterz@xxxxxxxxxxxxx> > > Cc: Steven Rostedt <rostedt@xxxxxxxxxxx> > > Cc: Al Viro <viro@xxxxxxxxxxxxxxxxxx> > > Cc: Kees Cook <keescook@xxxxxxxxxxxx> > > Cc: Petr Mladek <pmladek@xxxxxxxx> > > --- > > drivers/infiniband/hw/qib/qib.h | 2 +- > > drivers/infiniband/hw/qib/qib_file_ops.c | 2 +- > > 2 files changed, 2 insertions(+), 2 deletions(-) > > > > diff --git a/drivers/infiniband/hw/qib/qib.h b/drivers/infiniband/hw/qib/qib.h > > index 9363bccfc6e7..a8e1c30c370f 100644 > > --- a/drivers/infiniband/hw/qib/qib.h > > +++ b/drivers/infiniband/hw/qib/qib.h > > @@ -196,7 +196,7 @@ struct qib_ctxtdata { > > pid_t pid; > > pid_t subpid[QLOGIC_IB_MAX_SUBCTXT]; > > /* same size as task_struct .comm[], command that opened context */ > > - char comm[16]; > > + char comm[TASK_COMM_LEN]; > > /* pkeys set by this use of this ctxt */ > > u16 pkeys[4]; > > /* so file ops can get at unit */ > > diff --git a/drivers/infiniband/hw/qib/qib_file_ops.c b/drivers/infiniband/hw/qib/qib_file_ops.c > > index 63854f4b6524..7ab2b448c183 100644 > > --- a/drivers/infiniband/hw/qib/qib_file_ops.c > > +++ b/drivers/infiniband/hw/qib/qib_file_ops.c > > @@ -1321,7 +1321,7 @@ static int setup_ctxt(struct qib_pportdata *ppd, int ctxt, > > rcd->tid_pg_list = ptmp; > > rcd->pid = current->pid; > > init_waitqueue_head(&dd->rcd[ctxt]->wait); > > - strlcpy(rcd->comm, current->comm, sizeof(rcd->comm)); > > + strscpy_pad(rcd->comm, current->comm, sizeof(rcd->comm)); > > This should use (the adjusted) get_task_comm() instead of leaving this > open-coded. > Sure, that is better. > > ctxt_fp(fp) = rcd; > > qib_stats.sps_ctxts++; > > dd->freectxts--; > > -- > > 2.17.1 > > > > -- > Kees Cook -- Thanks Yafang