Re: [PATCH bpf-next v3 00/11] bpf: add support for new btf kind BTF_KIND_TAG

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hello:

This series was applied to bpf/bpf-next.git (refs/heads/master):

On Tue, 14 Sep 2021 15:30:04 -0700 you wrote:
> LLVM14 added support for a new C attribute ([1])
>   __attribute__((btf_tag("arbitrary_str")))
> This attribute will be emitted to dwarf ([2]) and pahole
> will convert it to BTF. Or for bpf target, this
> attribute will be emitted to BTF directly ([3], [4]).
> The attribute is intended to provide additional
> information for
>   - struct/union type or struct/union member
>   - static/global variables
>   - static/global function or function parameter.
> 
> [...]

Here is the summary with links:
  - [bpf-next,v3,01/11] btf: change BTF_KIND_* macros to enums
    https://git.kernel.org/bpf/bpf-next/c/41ced4cd8802
  - [bpf-next,v3,02/11] bpf: support for new btf kind BTF_KIND_TAG
    https://git.kernel.org/bpf/bpf-next/c/b5ea834dde6b
  - [bpf-next,v3,03/11] libbpf: rename btf_{hash,equal}_int to btf_{hash,equal}_int_tag
    https://git.kernel.org/bpf/bpf-next/c/30025e8bd80f
  - [bpf-next,v3,04/11] libbpf: add support for BTF_KIND_TAG
    https://git.kernel.org/bpf/bpf-next/c/5b84bd10363e
  - [bpf-next,v3,05/11] bpftool: add support for BTF_KIND_TAG
    https://git.kernel.org/bpf/bpf-next/c/5c07f2fec003
  - [bpf-next,v3,06/11] selftests/bpf: test libbpf API function btf__add_tag()
    https://git.kernel.org/bpf/bpf-next/c/71d29c2d47d1
  - [bpf-next,v3,07/11] selftests/bpf: change NAME_NTH/IS_NAME_NTH for BTF_KIND_TAG format
    https://git.kernel.org/bpf/bpf-next/c/3df3bd68d481
  - [bpf-next,v3,08/11] selftests/bpf: add BTF_KIND_TAG unit tests
    https://git.kernel.org/bpf/bpf-next/c/35baba7a832f
  - [bpf-next,v3,09/11] selftests/bpf: test BTF_KIND_TAG for deduplication
    https://git.kernel.org/bpf/bpf-next/c/ad526474aec1
  - [bpf-next,v3,10/11] selftests/bpf: add a test with a bpf program with btf_tag attributes
    https://git.kernel.org/bpf/bpf-next/c/c240ba287890
  - [bpf-next,v3,11/11] docs/bpf: add documentation for BTF_KIND_TAG
    https://git.kernel.org/bpf/bpf-next/c/48f5a6c41627

You are awesome, thank you!
--
Deet-doot-dot, I am a bot.
https://korg.docs.kernel.org/patchwork/pwbot.html





[Index of Archives]     [Linux Samsung SoC]     [Linux Rockchip SoC]     [Linux Actions SoC]     [Linux for Synopsys ARC Processors]     [Linux NFS]     [Linux NILFS]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]


  Powered by Linux