Hello: This series was applied to bpf/bpf-next.git (refs/heads/master): On Wed, 24 Mar 2021 18:51:24 -0700 you wrote: > This series adds support to allow bpf program calling kernel function. > > The use case included in this set is to allow bpf-tcp-cc to directly > call some tcp-cc helper functions (e.g. "tcp_cong_avoid_ai()"). Those > functions have already been used by some kernel tcp-cc implementations. > > This set will also allow the bpf-tcp-cc program to directly call the > kernel tcp-cc implementation, For example, a bpf_dctcp may only want to > implement its own dctcp_cwnd_event() and reuse other dctcp_*() directly > from the kernel tcp_dctcp.c instead of reimplementing (or > copy-and-pasting) them. > > [...] Here is the summary with links: - [v2,bpf-next,01/14] bpf: Simplify freeing logic in linfo and jited_linfo https://git.kernel.org/bpf/bpf-next/c/e16301fbe183 - [v2,bpf-next,02/14] bpf: Refactor btf_check_func_arg_match https://git.kernel.org/bpf/bpf-next/c/34747c412041 - [v2,bpf-next,03/14] bpf: Support bpf program calling kernel function https://git.kernel.org/bpf/bpf-next/c/e6ac2450d6de - [v2,bpf-next,04/14] bpf: Support kernel function call in x86-32 https://git.kernel.org/bpf/bpf-next/c/797b84f727bc - [v2,bpf-next,05/14] tcp: Rename bictcp function prefix to cubictcp https://git.kernel.org/bpf/bpf-next/c/d22f6ad18709 - [v2,bpf-next,06/14] bpf: tcp: Put some tcp cong functions in allowlist for bpf-tcp-cc https://git.kernel.org/bpf/bpf-next/c/e78aea8b2170 - [v2,bpf-next,07/14] libbpf: Refactor bpf_object__resolve_ksyms_btf_id https://git.kernel.org/bpf/bpf-next/c/933d1aa32409 - [v2,bpf-next,08/14] libbpf: Refactor codes for finding btf id of a kernel symbol https://git.kernel.org/bpf/bpf-next/c/774e132e83d0 - [v2,bpf-next,09/14] libbpf: Rename RELO_EXTERN to RELO_EXTERN_VAR https://git.kernel.org/bpf/bpf-next/c/0c091e5c2d37 - [v2,bpf-next,10/14] libbpf: Record extern sym relocation first https://git.kernel.org/bpf/bpf-next/c/aa0b8d43e953 - [v2,bpf-next,11/14] libbpf: Support extern kernel function https://git.kernel.org/bpf/bpf-next/c/5bd022ec01f0 - [v2,bpf-next,12/14] bpf: selftests: Rename bictcp to bpf_cubic https://git.kernel.org/bpf/bpf-next/c/39cd9e0f6783 - [v2,bpf-next,13/14] bpf: selftests: bpf_cubic and bpf_dctcp calling kernel functions https://git.kernel.org/bpf/bpf-next/c/78e60bbbe8e8 - [v2,bpf-next,14/14] bpf: selftests: Add kfunc_call test https://git.kernel.org/bpf/bpf-next/c/7bd1590d4eba You are awesome, thank you! -- Deet-doot-dot, I am a bot. https://korg.docs.kernel.org/patchwork/pwbot.html