On Tue, Dec 01, 2020 at 06:22:50PM -0800, Andrii Nakryiko wrote: > On Fri, Nov 27, 2020 at 10:01 AM Brendan Jackman <jackmanb@xxxxxxxxxx> wrote: [...] > > + > > +static void test_xchg(void) > > +{ > > + struct atomics_test *atomics_skel = NULL; > > nit: = NULL is unnecessary [...[ > > + CHECK(atomics_skel->data->xchg32_value != 2, "xchg32_value", > > + "32bit xchg left unexpected value (got %d want 2)\n", > > + atomics_skel->data->xchg32_value); > > + CHECK(atomics_skel->bss->xchg32_result != 1, "xchg_result", > > + "32bit xchg returned bad result (got %d want 1)\n", > > + atomics_skel->bss->xchg32_result); > > ASSERT_EQ() is less verbose. > > > + > > +cleanup: > > + atomics_test__destroy(atomics_skel); > > +} > > + > > +void test_atomics_test(void) > > +{ > > why the gigantic #ifdef/#else block if you could do the check here, > skip and exit? > > > + test_add(); > > + test_sub(); > > + test_and(); > > + test_or(); > > + test_xor(); > > + test_cmpxchg(); > > + test_xchg(); > > > please model these as sub-tests, it will be easier to debug, if anything > > > +} > > + > > +#else /* ENABLE_ATOMICS_TESTS */ > > + > > +void test_atomics_test(void) > > +{ > > + printf("%s:SKIP:no ENABLE_ATOMICS_TEST (missing Clang BPF atomics support)", > > + __func__); > > + test__skip(); > > +} > > + > > +#endif /* ENABLE_ATOMICS_TESTS */ > > diff --git a/tools/testing/selftests/bpf/progs/atomics_test.c b/tools/testing/selftests/bpf/progs/atomics_test.c > > new file mode 100644 > > index 000000000000..3139b00937e5 > > --- /dev/null > > +++ b/tools/testing/selftests/bpf/progs/atomics_test.c > > @@ -0,0 +1,124 @@ > > +// SPDX-License-Identifier: GPL-2.0 > > +#include <linux/bpf.h> > > +#include <bpf/bpf_helpers.h> > > +#include <bpf/bpf_tracing.h> > > + > > +#ifdef ENABLE_ATOMICS_TESTS > > + > > +__u64 add64_value = 1; > > +__u64 add64_result = 0; > > +__u32 add32_value = 1; > > +__u32 add32_result = 0; > > +__u64 add_stack_value_copy = 0; > > +__u64 add_stack_result = 0; > > empty line here > > > +SEC("fentry/bpf_fentry_test1") > > +int BPF_PROG(add, int a) > > +{ > > + __u64 add_stack_value = 1; > > + > > + add64_result = __sync_fetch_and_add(&add64_value, 2); > > + add32_result = __sync_fetch_and_add(&add32_value, 2); > > + add_stack_result = __sync_fetch_and_add(&add_stack_value, 2); > > + add_stack_value_copy = add_stack_value; > > + > > + return 0; > > +} > > + > > +__s64 sub64_value = 1; > > +__s64 sub64_result = 0; > > +__s32 sub32_value = 1; > > +__s32 sub32_result = 0; > > +__s64 sub_stack_value_copy = 0; > > +__s64 sub_stack_result = 0; > > same > > > +SEC("fentry/bpf_fentry_test1") > > +int BPF_PROG(sub, int a) > > +{ > > + __u64 sub_stack_value = 1; > > + > > + sub64_result = __sync_fetch_and_sub(&sub64_value, 2); > > + sub32_result = __sync_fetch_and_sub(&sub32_value, 2); > > + sub_stack_result = __sync_fetch_and_sub(&sub_stack_value, 2); > > + sub_stack_value_copy = sub_stack_value; > > + > > + return 0; > > +} > > + > > +__u64 and64_value = (0x110ull << 32); > > +__u64 and64_result = 0; > > +__u32 and32_value = 0x110; > > +__u32 and32_result = 0; > > yep > > > +SEC("fentry/bpf_fentry_test1") > > +int BPF_PROG(and, int a) > > +{ > > + > > + and64_result = __sync_fetch_and_and(&and64_value, 0x011ull << 32); > > + and32_result = __sync_fetch_and_and(&and32_value, 0x011); > > + > > + return 0; > > +} > > + > > +__u64 or64_value = (0x110ull << 32); > > +__u64 or64_result = 0; > > +__u32 or32_value = 0x110; > > +__u32 or32_result = 0; > > here too > > > +SEC("fentry/bpf_fentry_test1") > > +int BPF_PROG(or, int a) > > +{ > > + or64_result = __sync_fetch_and_or(&or64_value, 0x011ull << 32); > > + or32_result = __sync_fetch_and_or(&or32_value, 0x011); > > + > > + return 0; > > +} > > + > > +__u64 xor64_value = (0x110ull << 32); > > +__u64 xor64_result = 0; > > +__u32 xor32_value = 0x110; > > +__u32 xor32_result = 0; > > you get the idea... How often do you define global variables in > user-space code right next to the function without an extra line > between them?.. > [...] > > + cmpxchg64_result_succeed = __sync_val_compare_and_swap( > > + &cmpxchg64_value, 1, 2); > > + > > + cmpxchg32_result_fail = __sync_val_compare_and_swap( > > + &cmpxchg32_value, 0, 3); > > + cmpxchg32_result_succeed = __sync_val_compare_and_swap( > > + &cmpxchg32_value, 1, 2); > > single lines are fine here and much more readable Thanks, ack to all comments.