[ On Wed, Nov 4, 2020 at 2:01 PM Jiri Olsa <jolsa@xxxxxxxxxx> wrote: > > We need to generate just single BTF instance for the > function, while DWARF data contains multiple instances > of DW_TAG_subprogram tag. > > Unfortunately we can no longer rely on DW_AT_declaration > tag (https://gcc.gnu.org/bugzilla/show_bug.cgi?id=97060) > > Instead we apply following checks: > - argument names are defined for the function > - there's symbol and address defined for the function > - function is generated only once > > Also because we want to follow kernel's ftrace traceable > functions, this patchset is adding extra check that the > function is one of the ftrace's functions. > > All ftrace functions addresses are stored in vmlinux > binary within symbols: > __start_mcount_loc > __stop_mcount_loc > > During object preparation code we read those addresses, > sort them and use them as filter for all detected dwarf > functions. > > We also filter out functions within .init section, ftrace > is doing that in runtime. At the same time we keep functions > from .init.bpf.preserve_type, because they are needed in BTF. > > I can still see several differences to ftrace functions in > /sys/kernel/debug/tracing/available_filter_functions file: > > - available_filter_functions includes modules > - available_filter_functions includes functions like: > __acpi_match_device.part.0.constprop.0 > acpi_ns_check_sorted_list.constprop.0 > acpi_os_unmap_generic_address.part.0 > acpiphp_check_bridge.part.0 > > which are not part of dwarf data > - BTF includes multiple functions like: > __clk_register_clkdev > clk_register_clkdev > > which share same code so they appear just as single function > in available_filter_functions, but dwarf keeps track of both > of them > > With this change I'm getting 38353 BTF functions, which > when added above functions to consideration gives same > amount of functions in available_filter_functions. > > The patch still keeps the original function filter condition > (that uses current fn->declaration check) in case the object > does not contain *_mcount_loc symbol -> object is not vmlinux. > > Signed-off-by: Jiri Olsa <jolsa@xxxxxxxxxx> > --- Logic looks good, but the naming made it harder to understand what's going on, had to jump back and forth more than usual. Otherwise: Acked-by: Andrii Nakryiko <andrii@xxxxxxxxxx> > btf_encoder.c | 261 +++++++++++++++++++++++++++++++++++++++++++++++++- > 1 file changed, 259 insertions(+), 2 deletions(-) > > diff --git a/btf_encoder.c b/btf_encoder.c > index 1866bb16a8ba..df89b4467e4c 100644 > --- a/btf_encoder.c > +++ b/btf_encoder.c > @@ -26,6 +26,174 @@ > */ > #define KSYM_NAME_LEN 128 > > +struct symbols { "symbols" is a bit generic name, something like funcs_layout seems to convey the meaning a bit more precisely? > + unsigned long start; > + unsigned long stop; start/stop mcount, right? mcount part is important is important > + unsigned long init_begin; > + unsigned long init_end; > + unsigned long init_bpf_begin; > + unsigned long init_bpf_end; > + unsigned long start_section; start_section is quite ambiguous. That's the mcount section index, no? mcount_sec_idx? > +}; > + > +struct elf_function { > + const char *name; > + unsigned long addr; > + bool generated; > +}; > + [...] > + /* > + * Let's got through all collected functions and filter > + * out those that are not in ftrace and init code. > + */ > + for (i = 0; i < functions_cnt; i++) { > + struct elf_function *func = &functions[i]; > + > + /* > + * Do not enable .init section functions, > + * but keep .init.bpf.preserve_type functions. > + */ > + if (is_init(ms, func->addr) && !is_bpf_init(ms, func->addr)) > + continue; > + > + /* Make sure function is within ftrace addresses. */ > + if (bsearch(&func->addr, addrs, count, sizeof(addrs[0]), addrs_cmp)) { > + /* > + * We iterate over sorted array, so we can easily skip > + * not valid item and move following valid field into > + * its place, and still keep the 'new' array sorted. > + */ > + if (i != functions_valid) > + functions[functions_valid] = functions[i]; > + functions_valid++; > + } > + } can we re-assign function_cnt = functions_valid here? and functions_valid could be just a local temporary variable? > + > + free(addrs); > + return 0; > +} > + [...]