On Mon, Aug 10, 2020 at 5:41 AM Jean-Philippe Brucker <jean-philippe@xxxxxxxxxx> wrote: > > When building Arm NEON (SIMD) code, GCC emits built-in types __PolyXX_t, > which are not recognized by Clang. This causes build failures when > including vmlinux.h generated from a kernel built with CONFIG_RAID6_PQ=y > and CONFIG_KERNEL_MODE_NEON. Emit typedefs for these built-in types, > based on the Clang definitions. poly64_t is unsigned long because it's > only defined for 64-bit Arm. > > Including linux/kernel.h to use ARRAY_SIZE() incidentally redefined > max(), causing a build bug due to different types, hence the seemingly > unrelated change. > > Reported-by: Jakov Petrina <jakov.petrina@xxxxxxxxxx> > Signed-off-by: Jean-Philippe Brucker <jean-philippe@xxxxxxxxxx> > --- Thanks for sending small binaries (in little-endian, double thanks!) for me to look at generated DWARF and BTF. I have a bunch of naming nits below and a grudge against "long", but the approach looks reasonable to me overall. It's unfortunate we have to deal with GCC quirks like this. > tools/lib/bpf/btf_dump.c | 35 ++++++++++++++++++++++++++++++++++- > 1 file changed, 34 insertions(+), 1 deletion(-) > > diff --git a/tools/lib/bpf/btf_dump.c b/tools/lib/bpf/btf_dump.c > index cf711168d34a..3162d7b1880c 100644 > --- a/tools/lib/bpf/btf_dump.c > +++ b/tools/lib/bpf/btf_dump.c > @@ -13,6 +13,7 @@ > #include <errno.h> > #include <linux/err.h> > #include <linux/btf.h> > +#include <linux/kernel.h> > #include "btf.h" > #include "hashmap.h" > #include "libbpf.h" > @@ -549,6 +550,9 @@ static int btf_dump_order_type(struct btf_dump *d, __u32 id, bool through_ptr) > } > } > > +static void btf_dump_emit_int_def(struct btf_dump *d, __u32 id, > + const struct btf_type *t); > + > static void btf_dump_emit_struct_fwd(struct btf_dump *d, __u32 id, > const struct btf_type *t); > static void btf_dump_emit_struct_def(struct btf_dump *d, __u32 id, > @@ -671,6 +675,9 @@ static void btf_dump_emit_type(struct btf_dump *d, __u32 id, __u32 cont_id) > > switch (kind) { > case BTF_KIND_INT: > + /* Emit type alias definitions if necessary */ > + btf_dump_emit_int_def(d, id, t); let's call it btf_dump_emit_missing_aliases() or something like that, so it's clear that it's some sort of compatibility/legacy compiler handling. "emit_int_def" is way too generic and normal-looking. > + > tstate->emit_state = EMITTED; > break; > case BTF_KIND_ENUM: > @@ -870,7 +877,7 @@ static void btf_dump_emit_struct_def(struct btf_dump *d, > btf_dump_printf(d, ": %d", m_sz); > off = m_off + m_sz; > } else { > - m_sz = max(0, btf__resolve_size(d->btf, m->type)); > + m_sz = max(0LL, btf__resolve_size(d->btf, m->type)); > off = m_off + m_sz * 8; > } > btf_dump_printf(d, ";"); > @@ -890,6 +897,32 @@ static void btf_dump_emit_struct_def(struct btf_dump *d, > btf_dump_printf(d, " __attribute__((packed))"); > } > > +static const char *builtin_types[][2] = { again, something like "missing_base_types" would be a bit more prominent > + /* > + * GCC emits typedefs to its internal __PolyXX_t types when compiling > + * Arm SIMD intrinsics. Alias them to the same standard types as Clang. > + */ > + { "__Poly8_t", "unsigned char" }, > + { "__Poly16_t", "unsigned short" }, > + { "__Poly64_t", "unsigned long" }, In the diff ([0]) that Daniel referenced, seems like they are adding poly64_t to ARM32. What prevents GCC from doing that (or maybe they've already done that). So instead of making unreliable assumptions, let's define it as "unsigned long long" instead? [0] https://reviews.llvm.org/D79711 > + { "__Poly128_t", "unsigned __int128" }, > +}; > + > +static void btf_dump_emit_int_def(struct btf_dump *d, __u32 id, > + const struct btf_type *t) > +{ > + const char *name = btf_dump_type_name(d, id); > + int i; > + > + for (i = 0; i < ARRAY_SIZE(builtin_types); i++) { > + if (strcmp(name, builtin_types[i][0]) == 0) { > + btf_dump_printf(d, "typedef %s %s;\n\n", > + builtin_types[i][1], name); > + break; > + } > + } > +} > + > static void btf_dump_emit_enum_fwd(struct btf_dump *d, __u32 id, > const struct btf_type *t) > { > -- > 2.27.0 >