On Wed, May 13, 2020 at 12:36:18PM -0700, Linus Torvalds wrote: > > + arch_kernel_read(dst, src, type, err_label); \ > > I'm wondering if > > (a) we shouldn't expose this as an interface in general We do export something like it, currently it is called probe_kernel_address, and the last patch renames it to get_kernel_nofault. However it is implemented as a wrapper around probe_kernel_address / copy_from_kernel_nofault and thus not quite as efficient and without the magic goto semantics. > (b) it wouldn't be named differently.. It probably should with all the renaming..