On Wed, Apr 22, 2020 at 11:43:58AM -0700, H. Peter Anvin wrote: > On 2020-04-20 05:37, Jason Yan wrote: > > The '==' expression itself is bool, no need to convert it to bool again. > > This fixes the following coccicheck warning: > > > > arch/x86/net/bpf_jit_comp32.c:1478:50-55: WARNING: conversion to bool > > not needed here > > arch/x86/net/bpf_jit_comp32.c:1479:50-55: WARNING: conversion to bool > > not needed here > > > > Signed-off-by: Jason Yan <yanaijie@xxxxxxxxxx> > > --- > > arch/x86/net/bpf_jit_comp32.c | 4 ++-- > > 1 file changed, 2 insertions(+), 2 deletions(-) > > > > x32 is not i386. > > -hpa Hi! H. Peter Anvin and all I use the name "x86_32" to describe it in original commit 03f5781be2c7 ("bpf, x86_32: add eBPF JIT compiler for ia32"), but almost all following committers and contributors use the world "x32", I think it is short format for x{86_}32. Yes, I agree, "x32" isn't the right name here, I think "x32" is well known as a ABI, so maybe we should use "x86_32" or ia32 in future communication. Which one is the best name here? x86_32 or ia32 or anything other? Thanks!