On Sun, Mar 2, 2025 at 9:38 PM Peilin Ye <yepeilin@xxxxxxxxxx> wrote: > > Update documentation for the new load-acquire and store-release > instructions. Rename existing atomic operations as "atomic > read-modify-write (RMW) operations". rmw renaming looks like a churn. I don't think it adds clarity. > Following RFC 9669, section 7.3. "Adding Instructions", create new > conformance groups "atomic32v2" and "atomic64v2", where: > > * atomic32v2: includes all instructions in "atomic32", plus the new > 8-bit, 16-bit and 32-bit atomic load-acquire and > store-release instructions > > * atomic64v2: includes all instructions in "atomic64" and > "atomic32v2", plus the new 64-bit atomic load-acquire > and store-release instructions I think it's better for new groups to include only newly added insns. Also we probably should add barriers to kernel/llvm and only then update the doc with all insns together. Otherwise we very quickly get to atomicv3 and v4 groups. Naming wise I would call these two insns plus all barriers as barrier32 and barrier64 groups. cmpwait insn should probably be there as well.