Re: [PATCH bpf-next v2 1/7] bpf: Implement bpf_probe_read_kernel_dynptr helper

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On 2025/1/26 00:58, Alexei Starovoitov wrote:
> On Sat, Jan 25, 2025 at 12:30 AM Levi Zim via B4 Relay
> <devnull+rsworktech.outlook.com@xxxxxxxxxx> wrote:
>> From: Levi Zim <rsworktech@xxxxxxxxxxx>
>>
>> This patch add a helper function bpf_probe_read_kernel_dynptr:
>>
>> long bpf_probe_read_kernel_dynptr(const struct bpf_dynptr *dst,
>>          u32 offset, u32 size, const void *unsafe_ptr, u64 flags);
> We stopped adding helpers years ago.
> Only new kfuncs are allowed.

Sorry, I didn't know that. Just asking, is there any documentation/discussion
about stopping adding helpers?

I will switch the implementation to kfuncs in v3.

> This particular one doesn't look useful as-is.
> The same logic can be expressed with
> - create dynptr
> - dynptr_slice
> - copy_from_kernel

By copy_from_kernel I assume you mean bpf_probe_read_kernel. The problem
with dynptr_slice_rdwr and probe_read_kernel is that they only support a
compile-time constant size [1].

But in order to best utilize the space on a BPF ringbuf, it is possible to reserve a variable length of space as dynptr on a ringbuf with bpf_ringbuf_reserve_dynptr.

Then currently we have no way to read a variable length of kernel memory
into this dynptr, except doing it chunk by chunk[2], which is kinda awkward.
That's the problem the new helpers trying to solve.
And I am not the only one needing this kind of feature [3].

Andrii said it would be a straightforward addition as it is a super thin wrapper around existing functionality (we are just avoiding fixed buffer size restrictions of
existing probe/copy_from APIs)

[1]: https://elixir.bootlin.com/linux/v6.12.6/source/kernel/bpf/helpers.c#L2600-L2601 [2]: https://github.com/libbpf/libbpf-bootstrap/commit/046fad60df3e39540937b5ec6ee86054f33d3f28
[3]: https://github.com/libbpf/libbpf-rs/issues/1041
[4]: https://lore.kernel.org/bpf/CAEf4BzZctXJsR+TwMhmXNWnR0_BV802-3KJw226ZZt8St4xNkw@xxxxxxxxxxxxxx/

> pw-bot: cr




[Index of Archives]     [Linux Samsung SoC]     [Linux Rockchip SoC]     [Linux Actions SoC]     [Linux for Synopsys ARC Processors]     [Linux NFS]     [Linux NILFS]     [Linux USB Devel]     [Video for Linux]     [Linux Audio Users]     [Yosemite News]     [Linux Kernel]     [Linux SCSI]


  Powered by Linux